Difference between revisions of "Router - RouterOS and Routerboard"

Jump to navigation Jump to search
no edit summary
= Next Steps, Bonding a Second Line =
 
See http://0hq.net/RB/ros.txt for hints
To be continued.....
 
 
 
= Native IPv6 over PPPoE =
 
Once you have enabled the IPv6 package in RouterOS, and have an IPv6 range assigned on clueless, the PPPoE client will automatically create an IPv6 link.
 
To be able to use your address assignment add the address to a local interface or bridge:
<pre>/ipv6 address
add address=2001:8b0:XXX::1/64 advertise=yes comment="advertise on lan" disabled=no eui-64=no \
interface=ether2
</pre>
 
To route your traffic add a static route, or check Add Default Route on the PPPoE client:
<pre>/ipv6 route
add comment="" disabled=no distance=1 dst-address=::/0 gateway=pppoe-out scope=255 \
target-scope=10
</pre>
 
= 1500 MTU over PPPoE using baby jumbo frames =
 
PPPoE requires an 8 byte header to be added to each packet. This causes the payload to be restricted to a 1492 MTU if the underlying medium is regular Ethernet. The BT VDSL2 modem supports using baby jumbo frames of 1508 bytes so the PPP payload is now 1500 bytes which is the same as regular Ethernet.
 
A 1500 MTU is important because there are many networks and hosts out on the internet which are poorly configured and block all ICMP packets in an attempt to gain extra security but inadvertently breaking Path MTU Discovery.
 
Assuming the first Ethernet interface is used for PPPoE, set the MTU:
<pre>
/interface ethernet
set 0 comment="WAN Interface" disabled=no l2mtu=1524 mtu=1508 name=WAN
</pre>
 
Now add the pppoe-client ensuring MRU is set correctly:
<pre>/interface pppoe-client add-default-route=yes allow=chap comment="A&A" dial-on-demand=no disabled=no interface=WAN \ max-mru=1500 max-mtu=1500 name=PPPoE password=xxx profile=pppoe-client-default use-peer-dns=no user=xxx@xxx
</pre>
The LCPFix option needs to be enabled for this FTTC line on the Clueless configuration pages. RouterOS doesn't support RFC4638 so needs this option enabled.
 
Once all these changes have been made and the LCPFix option is enabled, the PPPoE connection should be restarted.
 
 
 
[[Category:Configuring]][[Category:IPv6]][[Category:ADSL]]
11

edits

Navigation menu